Developing Plugins with Maven 3

Maven is included in the Atlassian SDK, so you do not normally need to install it yourself. However, the version that the SDK bundles is Maven 2.1.0. This may be an obstacle for some who prefer or need to use Maven 3.

In previous versions of the SDK (and as previously described on this page), you needed to add repository proxies and modify your Maven settings file to use the SDK with Maven 3. 

Now you can simply follow the steps on Changing the Default Maven Version to use Maven 3 with the SDK. 

Powered by Confluence and Scroll Viewport