AMPS SDK 5.0.0 Release Notes

We've released AMPS 5.0.0 with a major version bump chiefly to indicate the major change in Maven support, rather than any significant functional changes.

Maven Support Changes

  • Maven 3.1 & 3.2 Support
    The AMPS SDK now comes bundled with Maven 3.2.1, but will also work with Maven 3.1.x
  • Dropping Maven 2.x Support
    Now that Maven 2 is end-of-life, we are also dropping support for this version of Maven in the AMPS SDK
  • Skipping Maven 3.0.x Support
    There are some serious bugs in the reactor in Maven 3.0, which have subsequently been fixed in version 3.1. We are thus skipping support for Maven 3.0.x

Other Minor Changes

  • Atlas CLI upgraded to use Maven CLI Plugin 1.0.11
    No longer shows 'maven2' at the command, allows reverse history search

  • AMPS-1136 Stash home/shared migration
    Supports Stash 3.1 directory locations

  • AMPS-1135 Upgrade the version of Tomcat for the container tomcat8x
    Now uses version 8.0.5 

Download

Was this page helpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport