Configuring your project to work with Bamboo

Configuring your project to work with JIRA is as simple as configuring the maven-bamboo-plugin that comes with the Atlassian Plugin SDK.

<plugin>
  <groupId>com.atlassian.maven.plugins</groupId>
  <artifactId>maven-bamboo-plugin</artifactId>
  <version>${amps.version}</version>
  <extensions>true</extensions>
  <configuration>
    <pluginArtifacts>
      <pluginArtifact>
        <groupId>com.atlassian.activeobjects</groupId>
        <artifactId>activeobjects-plugin</artifactId>
        <version>${ao.version}</version>
      </pluginArtifact>
      <pluginArtifact>
        <groupId>com.atlassian.activeobjects</groupId>
        <artifactId>activeobjects-bamboo-spi</artifactId>
        <version>${ao.version}</version>
      </pluginArtifact>
    </pluginArtifacts>
    <productVersion>${bamboo.version}</productVersion>
  </configuration>
</plugin>

where amps.version is the version of the Atlassian Plugin SDK you're using, and ao.version the version of the Active Objects plugin you're using. bamboo.version is the version of Confluence you want to use.

Was this page helpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport