Last updatedMay 12, 2019

Polyfills in Confluence Server

We bundle a small number of polyfills in order to support particular features. The following matrix lists all polyfills used in each Confluence version.

Confluence versionPolyfills
6.1 to 6.6 ES6-promise@3.0.2
webcomponentsjs/MutationObserver.js@0.7.5
6.7 to 6.12 ES6-promise@3.0.2
webcomponentsjs/MutationObserver.js@0.7.5
babel-polyfill@6.26.0
6.13 webcomponentsjs/MutationObserver.js@0.7.5
babel-polyfill@6.26.0
whatwg/fetch@2.0.4
abortcontroller-polyfill@1.1.9 (patch-fetch only)
6.14 and later babel-polyfill@7.2.5
whatwg/fetch@2.0.4
abortcontroller-polyfill@1.1.9 (patch-fetch only)

Note: there are some known issues with the Babel polyfill in Confluence 6.6 and earlier, see Babel Polyfill in Confluence Server for more information.