@Retention @Target @Inherited @Deprecated public abstract @interface

WebSudoRequired

implements Annotation
com.atlassian.confluence.security.websudo.WebSudoRequired

This @interface is deprecated.
since 3.4 - please use com.atlassian.sal.api.websudo.WebSudoRequired instead.

Class Overview

Any action method marked with this annotaion will require the WebSudo protection. Actions under "/admin" will not be effected by this annotation.

Summary

[Expand]
Inherited Methods
From interface java.lang.annotation.Annotation