Plugins that Cannot be Reloaded with FastDev or pi

FastDev and atlas-cli have been deprecated. Please use Automatic Plugin Reinstallation with QuickReload instead.

During development it is useful to use FastDev or the maven-cli pi command to reload a plugin in an actively running application, to provide rapid testing of changes. See Reloading a Plugin after Changes.

However, plugin modules can be marked with a @RequiresRestart annotation which means the plugin will not be reloaded until the application server is restarted. This means that the pi command does not work for these plugins.

Below is a list of plugin modules indicating if they require a restart or not.

JIRA

Module Type

Can be reloaded

Component

No

ComponentImport

Yes

ComponentTabPanel

No

CustomFieldSearcher

No

CustomFieldType

No

Gadget

Yes

IssueOperation

No

IssueTabPanel

No

JQLFunction

No

ModuleType

Yes

Portlet

No

ProjectTabPanel

No

Report

No

Resource

Yes

REST

Yes

RPC-SOAP

No

RPC-XMLRPC

No

SearchRequestView

No

ServletContextListener

Yes

ServletContextParameter

Yes

ServletFilter

Yes

Servlet

Yes

UserFormat

No

VersionTabPanel

No

WebItem

Yes

WebResource

Yes

WebSection

Yes

Webwork

No

WorkflowCondition

No

WorkflowFunction

No

WorkflowValidator

No

Confluence

All modules except Component will be reloaded

Bamboo

Everything not listed here can be reloaded.

Module Type

Can be reloaded

Component

No

BuildAgentRequirementFilter

No

CapabilityConfiguratorModule

No

CustomIndexReaderModule

No

CustomPostBuildIndexModule

No

CustomPreBuildQueuedActionModule

No

LegacyBuilderToTaskConverter

No

NotificationTypeModule

Yes Bamboo >=4.1

PlanDeletionInterceptorActionModule

No

RepositoryModule

No

SpringComponentModule

No

TriggerReasonModule

No

Fisheye/Crucible

Information to be completed. Component will not be reloaded.

Other information

Was this page helpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport