SAXParserContextProvider

Symptom: The provider class, class com.sun.jersey.core.impl.provider.xml.SAXParserContextProvider, could not be instantiated

Cause: Your pom.xml file likely has a compile (not test) dependency on jersey version 1.1.2-ea
http://jersey.576304.n2.nabble.com/Jersy-in-Jetty-Exceptions-td3481925.html suggests that different versions of jersey-core are involved in this problem.

Solution: Changing the jersey version 1.1.2 to 1.1.0 makes the error go away.

It's not clear what version of jersey is shipped with JIRA.

There is a JIRA Forum discussion about this here.

Was this page helpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport