Installing Active Objects

This page describes how to install the Atlassian Active Objects plugin into the Atlassian products, such as JIRA or Confluence. Where supported, the relevant version of Active Objects is bundled with the product.

Atlassian does not recommend that you install or upgrade Active Objects in a production environment, unless instructed by the Atlassian support team.

Active Objects in JIRA

Compatibility

  • The Active Objects plugin is compatible with JIRA 4.3 and later.
  • A developer preview of Active Objects is bundled with the JIRA 4.4.x series. This version of Active Objects is used by GreenHopper and by plugin developers for testing.
  • A production-ready version of Active Objects is bundled with JIRA 5.0 and later. There is therefore no need to install it unless you need a later version. See How to upgrade AO to 0.18.x in JIRA 5.

Notes

If you are planning to release a plugin that uses Active Objects, please target JIRA 5.0 or later. You should not ship a plugin for JIRA 4.4 that uses Active Objects. You should also not ask a customer to upgrade their version of Active Objects to suit your plugin.

To install Active Objects in JIRA:

  1. Download the latest version of the Active Objects plugin JAR.
  2. Download the appropriate version of the JIRA SPI plugin for Active Objects JAR:
  3. Install the JIRA SPI plugin using the manual plugin installation process.
  4. Install the JIRA Active Objects plugin using the manual plugin installation process.

If you had previously installed a plugin which depends on Active Objects you may need to re-enable it.

See also How to upgrade AO to 0.18.x in JIRA 5.

Active Objects in Confluence

Compatibility

  • The Active Objects plugin is compatible with Confluence 3.4 and later.
  • Active Objects in Confluence does not support DB2.
  • A production-ready version of Active Objects is bundled with Confluence 4.3 and later. There is no need to install it unless you need a later version.

Note

If you are planning to release a plugin that uses Active Objects, please target Confluence 4.3 or later. You should not ship a plugin for Confluence 4.2 or earlier that uses Active Objects. You should also not ask a customer to upgrade their version of Active Objects to suit your plugin.

To install Active Objects:

  1. Download the latest version of the Active Objects plugin JAR.
  2. Download the latest version of the Confluence SPI plugin for Active Objects JAR .
  3. Install the Confluence SPI plugin using the manual plugin installation process.
  4. Install the Active Objects plugin using the manual plugin installation process.

Active Objects in FishEye/Crucible

Compatibility

Active Objects is bundled with FishEye/Crucible 2.7 and later.

Note

The implementation of Active Objects in FishEye/Crucible is still a development preview. You should not ship a plugin for FishEye/Crucible that uses Active Objects, nor ask a customer to install Active Objects into FishEye/Crucible to suit your plugin.

Active Objects 0.15 is bundled by default. To install the latest version:

  1. Download the Active Objects plugin JAR.
  2. Follow the manual plugin installation process to install the plugin in FishEye/Crucible.

Active Objects in Bamboo

Compatibility

Active Objects is compatible with Bamboo 3.4 and later.

Note If you are planning to release a plugin that uses Active Objects, it's recommended to target Bamboo 5.4 or later.

Active Objects plugin is bundled by default.

Was this page helpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport