The Teamwork Graph API is available through Forge's Preview release phase.
Preview features are available to all users and receive the same level of support as generally available features. Schemas, fields, and behavior may still change before general availability (GA), and breaking changes are subject to a minimum 1-month deprecation notice, announced in the Teamwork Graph changelog.
To review the current limitations, see Limitations and considerations.
To share feedback or report an issue, visit the Atlassian developer community.
The AtlassianUserAssignedJiraWorkItem relationship represents the link between an Atlassian user and a Jira work item within the Teamwork Graph. It allows you to:
Relationship type: Canonical
| From object types | To object types |
|---|---|
Atlassian user - ati:cloud:identity:user | Jira work item - ati:cloud:jira:issue |
We recommend sending parameterized Cypher queries as below instead of embedding the parameters directly in the query string. This approach will help ensure better performance.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22query AtlassianUserAssignedJiraWorkItem_CypherQuery($cypherQuery: String!, $params: CypherRequestParams) { cypherQuery(query: $cypherQuery, params: $params) { edges { node { columns { value { ... on CypherQueryResultNode { id data { __typename ... on JiraWorkItem { id } } } } } } } } }
1 2 3 4 5 6 7{ "cypherQuery": "MATCH (user:AtlassianUser {ari: $id})-[:atlassian_user_assigned_jira_work_item]->(item:JiraWorkItem) RETURN item", "params": { "id": "$id" } }
| Name | Type | Properties |
|---|---|---|
creatorAri | Ari (Message) | |
statusCategory | StatusCategory (Enum) | |
issueType | IssueType (Message) | |
dueDate | Long | |
projectType | ProjectType (Enum) | |
actorAri | Ari (Message) |
When filtering by ARI in GraphQL, it will behave as a String rather than a message as shown below.
| Name | Type | Properties |
|---|---|---|
value | String |
| Name | Type | Properties |
|---|---|---|
hierarchyLevel | HierarchyLevel (Enum) | |
issueTypeName | IssueTypeName (Enum) |
| Name | Internal Name | Index |
|---|---|---|
not-set | STATUS_NOT_SET | 0 |
undefined | STATUS_UNDEFINED | 1 |
new | STATUS_NEW | 2 |
done | STATUS_DONE | 3 |
indeterminate | STATUS_INDETERMINATE | 4 |
| Name | Internal Name | Index |
|---|---|---|
not-set | TYPE_PROJECT_TYPE_NOT_SET | 0 |
service_desk | TYPE_PROJECT_TYPE_SERVICE_DESK | 1 |
business | TYPE_PROJECT_TYPE_BUSINESS | 2 |
software | TYPE_PROJECT_TYPE_SOFTWARE | 3 |
product_discovery | TYPE_PROJECT_TYPE_PRODUCT_DISCOVERY | 4 |
customer_service | TYPE_PROJECT_TYPE_CUSTOMER_SERVICE | 5 |
ops | TYPE_PROJECT_TYPE_OPS | 6 |
| Name | Internal Name | Index |
|---|---|---|
undefined | TYPE_HIERARCHY_LEVEL_NOT_SET | 0 |
subtask | TYPE_HIERARCHY_LEVEL_SUBTASK | 1 |
standard | TYPE_HIERARCHY_LEVEL_STANDARD | 2 |
epic | TYPE_HIERARCHY_LEVEL_EPIC | 3 |
initiative | TYPE_HIERARCHY_LEVEL_INITIATIVE | 4 |
| Name | Internal Name | Index |
|---|---|---|
not-set | TYPE_UNKNOWN | 0 |
Alerts | TYPE_ALERTS | 2 |
Bug | TYPE_BUG | 4 |
Epic | TYPE_EPIC | 10 |
Task | TYPE_TASK | 20 |
Story | TYPE_STORY | 30 |
Sub-task | TYPE_SUBTASK | 40 |
Sub-Task | TYPE_SUBTASK_1 | 50 |
Subtask | TYPE_SUBTASK_2 | 60 |
SUBTASK | TYPE_SUBTASK_3 | 70 |
Rate this page: