The Teamwork Graph API is available through Forge's Preview release phase.
Preview features are available to all users and receive the same level of support as generally available features. Schemas, fields, and behavior may still change before general availability (GA), and breaking changes are subject to a minimum 1-month deprecation notice, announced in the Teamwork Graph changelog.
To review the current limitations, see Limitations and considerations.
To share feedback or report an issue, visit the Atlassian developer community.
Contains related Confluence content ARIs for a piece of Confluence content, ranked by relevance.
A relationship is created for each recommended content item, with the relevance score stored as metadata.
This relationship covers Confluence-to-Confluence recommendations only; recommendations for other
Atlassian and third-party entities are stored on confluence-content-has-related-entity.
Relationship type: Activity
TTL (Time To Live): 180 days
| From object types | To object types |
|---|---|
Confluence blogpost - ati:cloud:confluence:blogpost | Confluence blogpost - ati:cloud:confluence:blogpost |
Confluence page - ati:cloud:confluence:page | Confluence page - ati:cloud:confluence:page |
We recommend sending parameterized Cypher queries as below instead of embedding the parameters directly in the query string. This approach will help ensure better performance.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25query ConfluenceContentHasRelatedConfluenceContent_CypherQuery($cypherQuery: String!, $params: CypherRequestParams) { cypherQuery(query: $cypherQuery, params: $params) { edges { node { columns { value { ... on CypherQueryResultNode { id data { __typename ... on ConfluencePage { id } ... on ConfluenceBlogpost { id } } } } } } } } }
1 2 3 4 5 6 7{ "cypherQuery": "MATCH (page:ConfluencePage {ari: $id})-[:confluence_content_has_related_confluence_content]->(page_1:ConfluencePage) RETURN page_1", "params": { "id": "$id" } }
| Name | Type | Properties |
|---|---|---|
score | Float | |
product | Product (Enum) |
| Name | Internal Name | Index |
|---|---|---|
unspecified | PRODUCT_UNSPECIFIED | 0 |
confluence | PRODUCT_CONFLUENCE | 100 |
google_drive | PRODUCT_GOOGLE_DRIVE | 120 |
microsoft_sharepoint | PRODUCT_SHAREPOINT | 130 |
Rate this page: