The Teamwork Graph API is available through Forge's Preview release phase.
Preview features are available to all users and receive the same level of support as generally available features. Schemas, fields, and behavior may still change before general availability (GA), and breaking changes are subject to a minimum 1-month deprecation notice, announced in the Teamwork Graph changelog.
To review the current limitations, see Limitations and considerations.
To share feedback or report an issue, visit the Atlassian developer community.
This relationship represents the link between an IdentityUser and a recommendation they dismissed on the Jira For You page.
Category of each dismissal is modelled in metadata as a list to allow users to dismiss the same entity (e.g. JiraIssue) across multiple categories independently.
Relationship type: Activity
TTL (Time To Live): 30 days
| From object types | To object types |
|---|---|
Atlassian user - ati:cloud:identity:user | Atlassian team - ati:cloud:identity:team |
External pull request - ati:cloud:jira:pull-request, ati:cloud:graph:pull-request | |
Jira space - ati:cloud:jira:project | |
Jira work item - ati:cloud:jira:issue | |
Jira work item comment - ati:cloud:jira:issue-comment |
We recommend sending parameterized Cypher queries as below instead of embedding the parameters directly in the query string. This approach will help ensure better performance.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31query AtlassianUserDismissedJiraForYouRecommendationEntity_CypherQuery($cypherQuery: String!, $params: CypherRequestParams) { cypherQuery(query: $cypherQuery, params: $params) { edges { node { columns { value { ... on CypherQueryResultNode { id data { __typename ... on JiraWorkItem { id } ... on JiraSpace { id } ... on JiraWorkItemComment { id } ... on AtlassianTeam { id } } } } } } } } }
1 2 3 4 5 6 7{ "cypherQuery": "MATCH (user:AtlassianUser {ari: $id})-[:atlassian_user_dismissed_jira_for_you_recommendation_entity]->(item:JiraWorkItem) RETURN item", "params": { "id": "$id" } }
| Name | Type | Properties |
|---|---|---|
dismissedCategories | CategoryDismissal (Message) | repeated |
| Name | Type | Properties |
|---|---|---|
category | RecommendationCategory (Enum) |
| Name | Internal Name | Index |
|---|---|---|
NOT_SET | CATEGORY_NOT_SET | 0 |
TEAM_INVITER_CONTEXT | CATEGORY_TEAM_INVITER_CONTEXT | 1 |
TEAM_POPULARITY | CATEGORY_TEAM_POPULARITY | 2 |
TEAM_COLLABORATORS_JOIN | CATEGORY_TEAM_COLLABORATORS_JOIN | 3 |
TEAM_COLLABORATORS_CREATE | CATEGORY_TEAM_COLLABORATORS_CREATE | 4 |
PROJECT_INVITER_CONTEXT | CATEGORY_PROJECT_INVITER_CONTEXT | 5 |
PROJECT_POPULARITY | CATEGORY_PROJECT_POPULARITY | 6 |
ISSUE_DUE_SOON | CATEGORY_ISSUE_DUE_SOON | 7 |
COMMENT_MENTION | CATEGORY_COMMENT_MENTION | 8 |
COMMENT_REPLY | CATEGORY_COMMENT_REPLY | 9 |
COMMENT_ASSIGNED | CATEGORY_COMMENT_ASSIGNED | 10 |
ISSUE_APPROVAL | CATEGORY_ISSUE_APPROVAL | 11 |
PR_REVIEW | CATEGORY_PR_REVIEW | 12 |
CONFLUENCE_LINKED_ISSUES | CATEGORY_CONFLUENCE_LINKED_ISSUES | 13 |
ISSUE_BLOCKING_ME | CATEGORY_ISSUE_BLOCKING_ME | 14 |
ISSUE_BLOCKED_BY_ME | CATEGORY_ISSUE_BLOCKED_BY_ME | 15 |
ISSUE_RECENTLY_UNBLOCKED | CATEGORY_ISSUE_RECENTLY_UNBLOCKED | 16 |
ISSUE_STUCK | CATEGORY_ISSUE_STUCK | 17 |
DELEGATE_TO_AGENT | CATEGORY_DELEGATE_TO_AGENT | 18 |
Rate this page: