The Teamwork Graph API is available through Forge's Preview release phase.
Preview features are available to all users and receive the same level of support as generally available features. Schemas, fields, and behavior may still change before general availability (GA), and breaking changes are subject to a minimum 1-month deprecation notice, announced in the Teamwork Graph changelog.
To review the current limitations, see Limitations and considerations.
To share feedback or report an issue, visit the Atlassian developer community.
The AtlassianUserMentionedInJiraWorkItemComment relationship represents the link between an Atlassian user and a Jira issue comment they are tagged in within the Teamwork Graph. It allows you to:
Relationship type: Canonical
| From object types | To object types |
|---|---|
Atlassian user - ati:cloud:identity:user | Jira work item comment - ati:cloud:jira:issue-comment |
We recommend sending parameterized Cypher queries as below instead of embedding the parameters directly in the query string. This approach will help ensure better performance.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22query AtlassianUserMentionedInJiraWorkItemComment_CypherQuery($cypherQuery: String!, $params: CypherRequestParams) { cypherQuery(query: $cypherQuery, params: $params) { edges { node { columns { value { ... on CypherQueryResultNode { id data { __typename ... on JiraWorkItemComment { id } } } } } } } } }
1 2 3 4 5 6 7{ "cypherQuery": "MATCH (user:AtlassianUser {ari: $id})-[:atlassian_user_mentioned_in_jira_work_item_comment]->(comment:JiraWorkItemComment) RETURN comment", "params": { "id": "$id" } }
| Name | Type | Properties |
|---|---|---|
statusCategory | StatusCategory (Enum) | |
projectType | ProjectType (Enum) | |
actorAri | Ari (Message) |
When filtering by ARI in GraphQL, it will behave as a String rather than a message as shown below.
| Name | Type | Properties |
|---|---|---|
value | String |
| Name | Internal Name | Index |
|---|---|---|
not-set | STATUS_NOT_SET | 0 |
undefined | STATUS_UNDEFINED | 1 |
new | STATUS_NEW | 2 |
done | STATUS_DONE | 3 |
indeterminate | STATUS_INDETERMINATE | 4 |
| Name | Internal Name | Index |
|---|---|---|
not-set | TYPE_PROJECT_TYPE_NOT_SET | 0 |
service_desk | TYPE_PROJECT_TYPE_SERVICE_DESK | 1 |
business | TYPE_PROJECT_TYPE_BUSINESS | 2 |
software | TYPE_PROJECT_TYPE_SOFTWARE | 3 |
product_discovery | TYPE_PROJECT_TYPE_PRODUCT_DISCOVERY | 4 |
customer_service | TYPE_PROJECT_TYPE_CUSTOMER_SERVICE | 5 |
ops | TYPE_PROJECT_TYPE_OPS | 6 |
Rate this page: