The Teamwork Graph API is available through Forge's Preview release phase.
Preview features are available to all users and receive the same level of support as generally available features. Schemas, fields, and behavior may still change before general availability (GA), and breaking changes are subject to a minimum 1-month deprecation notice, announced in the Teamwork Graph changelog.
To review the current limitations, see Limitations and considerations.
To share feedback or report an issue, visit the Atlassian developer community.
The JiraWorkItemHasChangedJiraStatus relationship represents the link between a Jira work item and a Jira work item status within the Teamwork Graph. It allows you to:
Relationship type: Activity
TTL (Time To Live): 30 days
| From object types | To object types |
|---|---|
Jira work item - ati:cloud:jira:issue | Jira work item status - ati:cloud:jira:issue-status |
We recommend sending parameterized Cypher queries as below instead of embedding the parameters directly in the query string. This approach will help ensure better performance.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22query JiraWorkItemHasChangedJiraStatus_CypherQuery($cypherQuery: String!, $params: CypherRequestParams) { cypherQuery(query: $cypherQuery, params: $params) { edges { node { columns { value { ... on CypherQueryResultNode { id data { __typename ... on JiraWorkItemStatus { id } } } } } } } } }
1 2 3 4 5 6 7{ "cypherQuery": "MATCH (item:JiraWorkItem {ari: $id})-[:jira_work_item_has_changed_jira_status]->(status:JiraWorkItemStatus) RETURN status", "params": { "id": "$id" } }
When filtering by ARI in GraphQL, it will behave as a String rather than a message as shown below.
| Name | Type | Properties |
|---|---|---|
value | String |
Rate this page: